Syslog Bugs (And Enhancement Requests)

Information and support for EnvisaLink modules.

Moderators: EyezOnRich, GrandWizard

Crikey
Posts: 78
Joined: Mon Aug 22, 2016 10:04 am

Syslog Bugs (And Enhancement Requests)

Postby Crikey » Mon Oct 29, 2018 10:08 am

There are a couple bugs with the syslog feature

  1. The configuration only allows for IP addresses that are within the /24 network of the EVL4's IP address. It should accept any IP address one wishes to give it, or at least obey the network mask.
  2. If the network address changes (e.g.: network from 192.168.10.0 -> 192.168.4.0), the configuration page shows the change, but, apparently the underlying software does not.

I finally got around #1 by giving my server a 2nd IP address, in the same /24 in which the EVL4 is addressed.

As to #2: I had squeezed-down my network addressing last night. Rebooted the EVL4 and verified it had reconnected to the Envisalerts server before heading off to bed. This morning discovered the panel was not logging to my syslog server. Snooped the network from that server. Nothing from the EVL4. Finally had to change the last octet in the Syslog Client Server IP Address, wait for the panel to finish initializing, then change it back again, before it would start sending syslog messages to the correct address.

Enhancement requests: It would be nice if logging included:

  1. Panel arm/disarm events (incl. source of arm/disarm?)
  2. User logins (incl. IP address, if possible?)
  3. User Password change events
  4. EnvisAlerts Status changes
  5. EnvisAlarm Status changes
And, I assume, for TPI users:

  1. EnvisAlert TPI Status changes
  2. TPI Sessions Alerts Enable changes

Thanks!

Return to “EnvisaLink ( IP100D, IP170D, 2DS, 3, 4)”

Who is online

Users browsing this forum: No registered users and 7 guests